Warp

已知问题

Debian10 部分内核下 linux-headers 无法通过 apt-get install linux-headers-$(uname -r) 完成安装

解决方案

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
reboot
sudo apt-get install linux-headers-$(uname -r) -y

手动安装版本教程:

原帖

Warp 优点

  •  Warp为没有IPV4的IPV6 Only的服务器增加IPV4
  •  Warp为没有IPV6的IPV4 Only的服务器增加IPV6
  •  Warp为拥有IPV4和IPV6隐藏真实的IPV4和IPV6
  •  Warp可以提供流媒体解锁服务(包括YouTube、Netflix等)
  •  Warp是完全免费的

本脚本的功能

  •  一键安装Warp
  •  支持没有IPV4的机器
  •  支持没有IPV6的机器
  •  三种模式:增加IPV4、增加IPV6、双栈

要求

支持 Ubuntu Debian CentOS7 (内核必须为 >= 5.X 4.X版本可能会导致linux-headers无法安装)

已测试CentOS7Ubuntu18Debian9Debian10可以成功运行

建议使用一下脚本升级你的内核为BBR最新版本

wget stern.codes/tcpx.sh && bash tcpx.sh

选择1安装原版BBR,安装完之后reboot,开机之后执行bash tcpx.sh,输入11启动BBR加速

使用

Github链接(必须拥有IPV4,IPV6不支持)

wget -O warp.sh https://raw.githubusercontent.com/missuo/CloudflareWarp/main/warp.sh && bash warp.sh

CDN链接(包含IPV4和IPV6)

wget -O warp.sh stern.codes/warp.sh && bash warp.sh

测试

IPV4 & IPV6测试

curl ipv4.ip.sb
curl ipv6.ip.sb

流媒体测试(感谢 Leo 提供的流媒体测试脚本)

Netflix

wget -O nf https://cdn.jsdelivr.net/gh/sjlleo/netflix-verify/CDNRelease/nf_2.60_linux_amd64 && chmod +x nf && clear && ./nf

YouTube

wget -O tubecheck https://cdn.jsdelivr.net/gh/sjlleo/TubeCheck/CDN/tubecheck_1.0beta_linux_amd64 && chmod +x tubecheck && clear && ./tubecheck

反馈

欢迎测试,并且在ISSUES中提出BUG,我会在第一时间修复

Github: https://github.com/missuo/CloudflareWarp